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Microsoft Excel is a spreadsheet program used to record, calculate, analyze, and visualize data. It is widely used in 

offices, schools, and businesses for handling numbers and data. 

 

Professional: - Microsoft Excel is a powerful spreadsheet application developed by Microsoft. It is used to enter, 

store, organize, and analyze data in a tabular form. Excel allows users to perform calculations using formulas and 

functions, create charts and graphs for data visualization, and manage large amounts of data efficiently. 

 

Excel Interface Components 

The Excel Interface is the layout of tools and elements that you see when you open Microsoft Excel. Understanding 

these parts helps you work efficiently in Excel. 

1. Workbook: 

An Excel file is called a Workbook. It contains one or more worksheets. 

2. Worksheet: 

A single spreadsheet page in Excel where you can enter and manage data. Each workbook can have multiple 

worksheets. 

3. Cell: 

The basic unit in Excel where you enter data. It is the intersection of a row and a column (e.g., A1, B2). 

4. Row: 

Rows are horizontal lines in a worksheet, labeled with numbers (1, 2, 3…). (Total Columns is 1048576) 

5. Column: 

Columns are vertical lines, labeled with letters (A, B, C…). (Total Columns is 16384) 

6. Active Cell: 

The currently selected cell where data can be entered or edited. It is highlighted with a thick border. 

7. Formula Bar: 

Located above the worksheet, it displays the content or formula of the active cell. 

8. Ribbon: 

A set of tabs (Home, Insert, Page Layout, etc.) containing command buttons and tools for performing tasks. 

9. Quick Access Toolbar: 

A customizable toolbar at the top-left corner that provides quick access to frequently used commands like 

Save, Undo, and Redo. 

10. Name Box: 

Displays the address (name) of the active cell (e.g., A1) and can be used to quickly select ranges. 

Introduction to MS Excel 1 
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11. Sheet Tabs: 

Located at the bottom of the Excel window, these tabs let you switch between different worksheets in the 

workbook. 

12. Status Bar: 

Located at the bottom, it shows information about selected data (like sum, average) and allows you to 

change worksheet views. 
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Short Key of Excel 2016 

Shortcut Description 

Ctrl + N New Workbook 

Ctrl + O Open Workbook 

Ctrl + S Save Workbook 

Ctrl + P Print Workbook 

Ctrl + C Copy selected cells 

Ctrl + X Cut selected cells 
 

Ctrl + V Paste copied/cut cells 

Ctrl + Z Undo last action 

Ctrl + Y Redo last undone action 

Ctrl + F Open Find dialog box 

Ctrl + H Open Replace dialog box 

Ctrl + A Select all cells 

Alt + E + S + V Paste Special options 

Ctrl + W Close current workbook 

Ctrl + Q Quick Analysis 

Ctrl + Arrow Keys Move to the edge of data region 

Home Move to the beginning of the row 

Ctrl + Home Move to the beginning of the worksheet 

Ctrl + End Move to the last cell with data 

Page Up Move one screen up 

Page Down Move one screen down 

Alt + Tab Switch between open applications 

Ctrl + B Bold selected text 

Ctrl + I Italicize selected text 

Ctrl + U Underline selected text 

Ctrl + 1 Open Format Cells dialog box 

Ctrl + Shift + L Toggle filters on/off 

Ctrl + Shift + '+' Insert a new row/column 

Ctrl + '-' Delete selected row/column 

Ctrl + Shift + '$' Format as currency 

Ctrl + Shift + '%' Format as percentage 

Ctrl + Shift + '!' Format as number with two decimal places 

Ctrl + Shift + '&' Add border around selected cells 

F2 Edit active cell 

Ctrl + Enter Fill selected cells with current entry 

Alt + Enter Start a new line within the same cell 

Ctrl + D Fill down (copy from the cell above) 

Ctrl + R Fill right (copy from the cell left) 

Ctrl + Shift + '+' Insert a new cell, row, or column 

Ctrl + Page Up Switch to the previous worksheet 

Ctrl + Page Down Switch to the next worksheet 

Shift + F11 Insert a new worksheet 

Ctrl + F4 Close workbook 

Ctrl + G Go to a specific cell 

F5 Open the 'Go To' dialog box 

Alt + H, O, W Auto resize the width of selected column 

Alt + H, O, H Auto resize the height of selected row 

Ctrl + Shift + F Open the Format Cells dialog box (Fonts tab) 

Ctrl + F12 Open the 'Open' dialog box for files 

Ctrl + Shift + O Select all cells with comments 
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  Alt + F3 Insert a name for the selected range 

Ctrl + Shift + '~' Apply General number format 

Ctrl + Shift + ' Copy the value from the cell above 

Ctrl + Shift + L Toggle filter on/off for the selected range 

Ctrl + T Create a Table 

Alt + F1 Create a default chart of selected data 

F11 Create a chart in a new worksheet 

Ctrl + 1 Open the Format Cells dialog box 

Ctrl + Shift + N Create a new blank workbook 

Ctrl + F2 Preview the print layout 

Ctrl + Shift + P Open the Print dialog box 

Ctrl + F4 Close workbook 

Ctrl + Shift + F4 Close all open Excel files 

Ctrl + Alt + F9 Force Excel to recalculate all formulas 

Ctrl + Shift + F9 Recalculate the entire workbook 

Alt + Shift + F1 Insert a new worksheet 

Ctrl + Shift + E Open the 'Evaluate Formula' window 

Ctrl + ; Enter the current date 

Ctrl + Shift + ; Enter the current time 

Alt + N + V Open the 'Insert PivotTable' dialog box 

Ctrl + Shift + U Expand or collapse the formula bar 

Ctrl + T Create a Table 

Alt + F1 Create a default chart of selected data 

Ctrl + Shift + F3 Create names from selection 

Ctrl + Shift + P Open Print Preview 

Ctrl + F6 Switch between open workbooks 

Ctrl + F3 Define a name (named range) 

Ctrl + Shift + F3 Create names from selection 

Alt + D + F + F Open Filter menu 

Ctrl + Shift + P Open Print Preview 
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The Home tab is the default tab in Excel and contains the most commonly used commands for formatting and 

editing data. It is divided into several groups: 

 

Clipboard Group 

 Cut (Ctrl + X): Removes the selected data and stores it on the clipboard. 

 Copy (Ctrl + C): Copies the selected data to the clipboard. 

 Paste (Ctrl + V): Pastes data from the clipboard. 

 Format Painter: Copies formatting from one place and applies it to another. 

How to Use Format Painter  

1. Select the cell that contains the formatting you want to copy. 
2. Go to the Home tab on the Ribbon. 

3. In the Clipboard group, click on the Format Painter (🖌️ brush icon). 
4. Click on the cell or drag over the range where you want to apply the copied formatting. 

 

Font Group 

 Font Type and Size: Change the style and size of text. 

 Bold (B), Italic (I), Underline (U): Format the text style. 

 Font Color: Change the color of the text. 

 Fill Color: Change the background color of a cell. 

 Borders: Add borders to cells. 

How to Use Borders in Excel 

1. Select the cell(s) where you want to apply borders. 
2. Go to the Home tab on the Ribbon. 
3. In the Font group, click on the Borders dropdown button. 
4. Choose a border style from the options: 

o Bottom Border: Adds a border at the bottom of the selected cells. 
o Top Border: Adds a border at the top. 
o Left Border: Adds a border on the left. 
o Right Border: Adds a border on the right. 
o All Borders: Adds borders to all sides of the selected cells. 
o Outside Borders: Adds borders only to the outer edges of the selected range. 
o Thick Box Border: Adds a thicker border around the selected range. 
o More Borders: Opens the Format Cells dialog box for more advanced border options, such 

as color and line styles. 
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To Remove Borders: 

1. Select the cell(s) where you want to remove borders. 
2. Go to the Home tab. 
3. In the Font group, click on the Borders dropdown. 
4. Choose No Border to remove all borders. 

Alignment Group 

 Horizontal and Vertical Alignment: Align text left, center, or right. 

 

 

 

 Wrap Text: Displays all the content within a cell by wrapping the text onto multiple lines. 

 

 

 Merge & Center: Combines multiple cells into one and centers the content. 

Number Group 

 Number Format: Change how numbers are displayed (e.g., General, Currency, Percentage, Date). 

Rs. 6556 Rupees  58% Percentage 

INR 645 Rupees 18:59 Time 

 

How to Use Number Format in Excel 

1. Select the cell(s) that contain the numbers you want to format. 
2. Go to the Home tab on the Ribbon. 
3. In the Number group, you'll find a dropdown to change the number format. 
4. Choose a number format from the options: 

o General: The default format. Numbers are displayed without any specific formatting. 
o Number: Displays numbers with a comma separator for thousands and decimal places. 

 You can adjust the number of decimal places and whether to use a comma 
separator. 

o Currency: Formats the number as a monetary value (e.g., $1,000.00). 
 You can select the currency symbol you prefer (e.g., $, €, £). 

o Accounting: Similar to Currency but aligns the currency symbols and decimal points. 
o Short Date / Long Date: Formats numbers as dates (e.g., 1/1/2025 for Short Date). 
o Time: Formats the number as time (e.g., 12:00 PM). 
o Percentage: Multiplies the number by 100 and adds a percentage sign (e.g., 50%). 
o Fraction: Displays numbers as fractions (e.g., 1/2, 3/4). 
o Scientific: Converts the number into scientific notation (e.g., 1.23E+03). 
o Text: Treats numbers as text, preserving leading zeros (e.g., 00123) 

 Increase/Decrease Decimal: Adjust the number of decimal places. 

Ram Bahardur 

Prashad 
 Ram Bahardur Prashad 
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6464.322222 Rupees 6464.322222 After 

 

Styles Group 

 Conditional Formatting 

Conditional Formatting in Excel is used to automatically apply formatting (such as colors, icons, or data bars) 
to cells based on the cell's value or a condition. 

 

 

How to Use Conditional Formatting  

1. Select the cell(s) that you want to apply conditional formatting to. 
2. Go to the Home tab on the Ribbon. 
3. In the Styles group, click on Conditional Formatting. 
4. Choose one of the following options: 

o Highlight Cell Rules: 
 Greater Than / Less Than: Format cells based on a comparison with a specific value. 
 Between: Format cells if their value is between two numbers. 
 Equal To: Format cells that are equal to a specified value. 
 Text that Contains: Format cells containing specific text. 
 A Date Occurring: Format cells with dates falling within a certain range (e.g., today, 

next week). 
o Top/Bottom Rules: 

 Top 10 Items / Bottom 10 Items: Format the top or bottom N items in a range. 
 Top 10% / Bottom 10%: Format the top or bottom percentage of items in a range. 

o Data Bars: 
 Apply colored bars inside cells to show relative values. The longer the bar, the higher 

the value. 
o Color Scales: 

 Apply a color gradient based on cell values, allowing you to visually compare data. 
For example, high values can be green, and low values can be red. 

o Icon Sets: 
 Apply icons (like arrows or traffic lights) to represent values based on their 

magnitude. 
5. Customize the Format: 

o After selecting an option, you can customize the formatting rules, such as the colors or 
values, by selecting Manage Rules.| 
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To Remove Conditional Formatting: 

1. Select the cells with the applied conditional formatting. 
2. Go to the Home tab. 
3. In the Styles group, click on Conditional Formatting. 
4. Choose Clear Rules and select from: 

o Clear Rules from Selected Cells 
o Clear Rules from Entire Sheet 

 

 Format as Table: Quickly formats a range as a table. 

 

 

Format as Table 

1. Select the range of cells that you want to format as a table (including headers if you have them). 
2. Go to the Home tab on the Ribbon. 
3. In the Styles group, click on Format as Table. 
4. Choose a table style from the available options. 
5. A dialog box will appear, confirming the range. If your data has headers, make sure the box "My 

table has headers" is checked. 
6. Click OK. Your selected data will now be formatted as a table. 

Benefits of Formatting as Table: 

 Automatically applies style to your data. 
 Makes it easier to sort and filter data. 
 Enables structured references for formulas. 

 

 Cell Styles 

Cell Styles are predefined formatting options in Excel that allow you to quickly apply consistent formatting 
(such as font, color, and borders) to cells. 

1. Select the cell(s) you want to format. 
2. Go to the Home tab. 
3. In the Styles group, click on Cell Styles. 
4. Choose a style from the gallery. 
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Cells Group 

The Cells group on the Home tab contains tools for managing the structure of your worksheet, such as inserting, 
deleting, and formatting cells, rows, and columns. 

1. Insert: Add new cells, rows, or columns. 
2. Delete: Remove cells, rows, or columns. 
3. Format: The Format Cells option allows you to change the appearance of cells including number format, 

alignment, font, border, fill, and protection. 

How to use Format: 

1. Select the cell(s). 
2. Right-click and choose Format Cells, or go to Home tab → Cells group → Format → Format 

Cells. 
3. Use the tabs (Number, Alignment, Font, Border, Fill, and Protection) to apply formatting. 
4. Click OK to apply. 
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Editing Group 

 AutoSum: Quickly adds up a range of numbers. 
 Fill 

Fill is used to apply a background color to selected cells or to automatically fill data using patterns or series. 

To Apply Fill Color: 

1. Select the cell(s). 
2. Go to Home tab → Font group → Fill Color (paint bucket icon). 
3. Choose a color to fill the cells. 

To Auto Fill Series: 

1. Enter data (e.g., 1, 2). 
2. Select the cells. 
3. Drag the fill handle (small square at the corner) to continue the series. 

 

 Clear: Removes content, formatting, or comments. 
 Sort & Filter 

Sort & Filter helps organize data by arranging it in a specific order or displaying only the data you need. 

To Sort Data: 

1. Select the data range. 
2. Go to Home tab → Editing group → Sort & Filter. 
3. Choose Sort A to Z, Z to A, or Custom Sort. 

To Filter Data: 

1. Select the header row. 
2. Go to Home tab → Sort & Filter → Filter. 
3. Click the dropdown arrows in the headers to select filter options. 

 

 Find & Select: Search for specific text or formatting. 
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The Insert tab provides tools to add visual and functional elements like tables, charts, images, and more into your 

worksheet. 

 

Tables Group 

 Table 

A Table in Excel is a structured range that makes it easier to manage, sort, filter, and analyze related data. 

Steps to Create a Table: 

1. Select your data range. 
2. Go to Insert tab → Tables group → Table. 
3. Confirm the range and check "My table has headers" if applicable. 
4. Click OK – your data is now formatted as a table. 

 

 PivotTable 

A PivotTable is a powerful tool used to quickly summarize, analyze, and explore large amounts of data. 

Steps to Create a PivotTable: 

1. Select your data range. 
2. Go to Insert tab → Tables group → PivotTable. 
3. Choose the location for the PivotTable (new or existing worksheet). 
4. Click OK, then drag fields into Rows, Columns, Values, and Filters. 

 

 Recommended PivotTables: Offers automatic PivotTable suggestions based on your data. 
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Illustrations Group 

The Illustrations group allows you to insert visual elements to enhance your worksheet. 

 Pictures: Add images from your computer sources. 
 Online Pictures: Add images from online sources. 
 Shapes: Insert ready-made shapes like arrows, circles, etc. 
 Icons: Add built-in icons to illustrate content. 

Pictures allow you to insert images from your computer into your worksheet to enhance visual 
understanding. 

Steps to Insert a Picture: 

1. Go to Insert tab → Illustrations group → Pictures. 
2. Click This Device. 
3. Browse and select the image file. 
4. Click Insert – the picture will appear in your worksheet. 

 

                            

 

 SmartArt 

SmartArt is used to create diagrams like processes, hierarchies, and cycles to visually represent information. 

Steps to Insert SmartArt: 

1. Go to Insert tab → Illustrations group → SmartArt. 
2. Choose a layout (e.g., Process, Hierarchy, Cycle). 
3. Click OK and enter your text in the diagram. 
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Charts Groups 

The Charts group lets you insert visual representations of your data to make it easier to understand and analyze. 

 Column Chart – compares values vertically. 
 Line Chart – shows trends over time. 
 Pie Chart – displays proportions as slices. 
 Bar Chart – compares values horizontally. 
 Area Chart – emphasizes magnitude of change over time. 
 Scatter (XY) Chart – shows relationships between values. 
 Combo Chart – mixes two chart types in one. 

 

 

 

 

 

 

 

Sparkline’s Groups 

 Sparklines 

Sparklines are tiny charts that fit in a single cell and show trends or patterns in a row of data. 

Steps to Insert Sparklines: 

1. Select the cell where you want the sparkline. 
2. Go to Insert tab → Sparklines group. 
3. Choose a type: Line, Column, or Win/Loss. 
4. Select the data range and click OK. 

 

Links Groups 

The Links group allows you to insert and manage hyperlinks in your worksheet. 

 Link (Hyperlink): Add a link to a webpage, file, email, or another cell/sheet. 
 Recent Links: Quickly access recently used links. 
 Bookmark (in some versions): Jump to specific parts within a file. 

Steps to Insert a Link: 

1. Select a cell or text. 
2. Go to Insert tab → Links group → Link. 
3. Choose link type (e.g., Existing File, Web Page, Place in This Document). 
4. Click OK. 
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Text Group  

The Text group allows you to insert various text-related elements into your worksheet. 

 Text Box 

A Text Box lets you insert and position text anywhere in the worksheet, independent of cell boundaries. 

Steps to Insert a Text Box: 

1. Go to Insert tab → Text group → Text Box. 
2. Click and drag on the worksheet to draw the box. 
3. Type your desired text inside the box. 

 

 

 

 

 

 

 Header & Footer 

Header & Footer are sections at the top (header) and bottom (footer) of printed pages where you can add 
text like titles, dates, or page numbers. 

Steps to Insert Header & Footer: 

1. Go to Insert tab → Text group → Header & Footer. 
2. Excel switches to Page Layout View. 
3. Click inside the header or footer area and type your text (or use options like page number, file name, 

etc.). 

 

 WordArt 

WordArt is decorative text that allows you to add stylized titles or headings with special effects like 
shadows, outlines, and colors. 

Steps to Insert WordArt: 

1. Go to Insert tab → Text group → WordArt. 
2. Choose a WordArt style. 
3. Type your text in the placeholder box that appears on the sheet. 
4. Use the Format tab to adjust style, size, and effects. 
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 Signature Line 

Signature Line allows you to add a placeholder for a digital or handwritten signature in your worksheet. 

Steps to Insert Signature Line: 

1. Go to Insert tab → Text group → Signature Line. 
2. Choose Microsoft Office Signature Line. 
3. Fill in signer details (name, title, etc.). 
4. Click OK – a signature box will appear in the sheet. 

 

 Object 

The Object feature lets you insert files, documents, or other embedded items (like Word, PDF, or images) 
into your worksheet. 

Steps to Insert an Object: 

1. Go to Insert tab → Text group → Object. 
2. In the dialog box, choose: 

o Create New to insert a new file type (e.g., Word Document). 
o Create from File to embed an existing file. 

3. Browse and select the file, then click OK. 

 

Symbols Group 

 Symbols 

Symbols allow you to insert special characters, mathematical symbols, and foreign language letters into your 

worksheet. 

Steps to Insert a Symbol: 

1. Go to Insert tab → Text group → Symbol. 
2. In the dialog box, select the symbol or character you want to insert. 
3. Click Insert and then Close. 
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The Data tab provides tools for managing and analyzing data, including sorting, filtering, and data validation. 

 

Sort & Filter Group 

Sort & Filter tools in Excel allow you to organize data by sorting it and filtering out specific information. 

Sort: 

1. Sort A to Z: Organizes data in ascending order (e.g., alphabetically or numerically). 
2. Sort Z to A: Organizes data in descending order. 
3. Custom Sort: Sort by multiple columns or specific criteria. 

Filter: 

1. Filter: Displays a dropdown list for each column header to filter and show only the data you want 
(e.g., specific dates, values, or text). 

2. Clear Filter: Removes any applied filters. 

 

 

 

 

 

 

Get & Transform Data Group 

Get & Transform Data (formerly known as Power Query) helps you import, clean, and transform data from 
various sources like databases, web pages, or files. 

Steps to Use Get & Transform Data: 

1. Go to Data tab → Get & Transform Data group. 
2. Click Get Data, then choose the data source (e.g., From File, From Database, From Web). 
3. Follow the prompts to load the data into Excel. 
4. Use the Power Query Editor to clean and transform the data (filter, merge, etc.). 
5. Click Close & Load to load the cleaned data back into the worksheet. 

Data Tools Group 

The Data Tools group on the Data tab provides several features for managing and organizing data in your 
worksheet. 
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 Text to Columns: Splits a column of text into multiple columns based on a delimiter (e.g., commas, 
spaces). 

 Remove Duplicates: Eliminates duplicate values from a selected range or column. 
 Consolidate: Combines data from multiple ranges into one, useful for summary reports. 

 Flash Fill: Automatically fills in data based on patterns you specify. 
 Data Validation:  

Data Validation allows you to control the type of data entered into a cell, ensuring that only valid data is 
entered based on your criteria. 

Steps to Apply Data Validation: 

1. Select the cell(s) where you want to apply validation. 
2. Go to Data tab → Data Tools group → Data Validation. 
3. In the Data Validation dialog box, set the criteria (e.g., whole numbers, dates, specific list of 

values). 
4. Optionally, set input messages or error alerts to guide users. 

Example Use: 

 Restricting entries to numbers between 1 and 100. 
 Creating a dropdown list of options to select from. 

Outline Group 

The Outline feature allows you to group and summarize data, making it easier to navigate and analyze large 

datasets. 

 Group: Organizes data into collapsible groups to hide or show sections. 
 Ungroup: Removes grouping from selected rows or columns. 

The Group feature allows you to organize data into collapsible sections, making it easier to manage large 
datasets by hiding or displaying details. 

Steps to Group Data: 

1. Select the rows or columns you want to group. 
2. Go to Data tab → Outline group → Group. 
3. In the dialog box, select either Rows or Columns to group. 
4. Click OK – the selected rows/columns will be grouped, and you’ll see a minus sign (–) to collapse 

or expand the group. 

To Ungroup: 

1. Select the grouped data. 
2. Go to Data tab → Outline group → Ungroup. 
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 Subtotal: Automatically adds subtotals for grouped data. 

The Subtotal feature allows you to insert automatic subtotals for grouped data, making it easier to 
summarize large datasets. 

Steps to Insert Subtotals: 

1. Ensure your data is sorted by the column you want to group (e.g., by product category). 
2. Go to Data tab → Outline group → Subtotal. 
3. In the Subtotal dialog box: 

o Choose the column to group by. 
o Select the function (e.g., SUM, AVERAGE) for the subtotal. 
o Specify the column(s) to apply the subtotal to. 

4. Click OK – Excel will insert subtotal rows for each group. 

To Remove Subtotals: 
Go to Data tab → Outline group → Remove Subtotals 

 

   

http://www.satyaeducation.com/


Satya Education | Best Computer Institute in Naya Gaon, SAS Nagar, Punjab,  9815634790 
 

Visit for more information and eBooks      www.satyaeducation.com 

 

 

 

 

The Page Layout tab provides tools for adjusting the appearance of your worksheet when printed, including page 
setup, themes, and alignment options. 

Key Features in Page Layout Tab: 

Themes 

Themes in Excel allow you to apply a consistent set of formatting options (such as colors, fonts, and effects) 
across your entire workbook for a professional and unified look. 

Steps to Apply a Theme: 

1. Go to the Page Layout tab → Themes group. 
2. Click on Themes and choose from the available options (e.g., Office, Colorful, Dark, etc.). 
3. Excel will automatically update the workbook's colors, fonts, and effects to match the selected 

theme. 

Customizing Themes: 
You can also create a custom theme by selecting Colors, Fonts, and Effects individually. 

 

Page Setup 

 Orientation in Excel: 

The Orientation option determines the direction of the printed page. 

 Portrait: Vertical orientation (default for most documents). 
 Landscape: Horizontal orientation, useful for wide tables or charts. 

Steps: 

1. Go to Page Layout tab → Page Setup group → Orientation. 
2. Select Portrait or Landscape. 
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 Margins in Excel: 

Margins define the amount of space between your content and the edges of the paper. 

 Normal: Default margin settings. 
 Wide: Larger space between content and edges. 
 Narrow: Smaller space for more content on the page. 
 Custom: Manually set the margin size. 

Steps: 

1. Go to Page Layout tab → Page Setup group → Margins. 
2. Choose your desired margin setting or click Custom Margins for manual adjustments. 

 

 Size in Excel: 

The Size option lets you select the paper size for printing. 

 Common sizes include A4, Letter, Legal, etc. 

Steps: 

1. Go to Page Layout tab → Page Setup group → Size. 
2. Choose the paper size from the list or set a custom size. 

 

 Print Area in Excel: 

The Print Area defines which part of the worksheet will be printed. 

 You can set a specific range of cells as the print area. 

Steps: 

1. Select the range you want to print. 
2. Go to Page Layout tab → Page Setup group → Print Area → Set Print Area. 

 

 Headers & Footers in Excel: 

Headers & Footers allow you to add information like page numbers, dates, and titles at the top or bottom of 

each printed page. 

Steps: 

1. Go to Page Layout tab → Page Setup group → Header & Footer. 
2. Click to add custom text or use pre-set options (like page numbers or file names). 
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 Scaling in Excel: 

Scaling adjusts the size of the worksheet content to fit it on the desired number of printed pages. 

 Fit to One Page: Shrinks the content to fit on one page. 
 Custom Scaling: Adjust the print size to a specific percentage. 

Steps: 

1. Go to Page Layout tab → Page Setup group → Scale to Fit. 
2. Adjust the Width, Height, or Scale percentage as needed. 

 

Scale to Fit 

Scale to Fit helps you adjust the size of your worksheet content to ensure it fits within the specified number 
of pages when printed, without needing to manually adjust the content or margins. 

Key Options in Scale to Fit: 

 Width: Defines how many pages wide the printed content should be. You can set it to fit within one 
page, or a specific number of pages. 

 Height: Defines how many pages tall the printed content should be. 
 Scale: Allows you to set a custom percentage for the size of the printed content. 

Steps to Use Scale to Fit: 

1. Go to Page Layout tab → Page Setup group → Scale to Fit. 
2. Adjust the Width, Height, or Scale options to control how the content fits on the printed page. 

o Width: Set to "1 page" to fit the content within one page wide. 
o Height: Set to "1 page" to fit the content within one page tall. 
o Scale: Set a custom percentage (e.g., 80%) to shrink or enlarge the content. 

 

Sheet Options 

The Sheet Options group in the Page Layout tab allows you to control how gridlines and headings appear 
when printing the worksheet. 

Key Features in Sheet Options: 

 Gridlines: Allows you to show or hide the gridlines (the lines separating cells) when printing the 
worksheet. 

o Show gridlines: Displays the gridlines in the printed document. 
o Print gridlines: Ensures that gridlines are printed, even if they aren't visible on the screen. 

 Headings: Controls whether row and column headings (A, B, C, 1, 2, 3) appear in the printed 
document. 

o Print headings: Prints the column and row labels (A, B, C, 1, 2, 3) on each page. 
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Steps to Adjust Sheet Options: 

1. Go to the Page Layout tab → Sheet Options group. 
2. Check or uncheck the Gridlines and Headings boxes based on your preference. 

o Gridlines: For visible gridlines, check the box for Print. 
o Headings: To print the row/column labels, check the Print box. 

 

Arrange 

The Arrange group in the Page Layout tab allows you to organize and manage objects (like images, shapes, 
charts, etc.) within your worksheet. 

 Bring Forward / Send Backward 

These options are used to change the stacking order of objects (like shapes, pictures, or charts) when they 
overlap. 

 Bring Forward: Moves the selected object one level up, making it appear on top of others. 
 Send Backward: Moves the selected object one level down, placing it behind other overlapping 

objects. 

You can also use: 

 Bring to Front: Brings the object to the very top. 
 Send to Back: Sends the object behind all other objects. 

Steps: 

1. Select the object (e.g., image or shape). 
2. Go to Page Layout tab → Arrange group. 
3. Click Bring Forward or Send Backward as needed. 

 

 Align:  

The Align option is used to position multiple objects (like shapes, images, or charts) precisely in relation to 
each other or the worksheet. 

Common Align Options: 

 Align Left / Center / Right – Aligns objects horizontally. 
 Align Top / Middle / Bottom – Aligns objects vertically. 
 Distribute Horizontally / Vertically – Evenly spaces multiple objects. 

Steps to Use Align: 

1. Select two or more objects (hold Ctrl and click each). 
2. Go to Page Layout tab → Arrange group → Align. 
3. Choose the desired alignment option from the dropdown. 

Note: To align objects to the worksheet (not just each other), check “Align to Page” before choosing the 
alignment. 
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 Group:  

The Group option lets you combine multiple objects (like shapes, images, or charts) so they act as one single 
object. This makes it easier to move, resize, or format them together. 

Steps to Group Objects: 

1. Select the objects (hold Ctrl and click each one). 
2. Go to Page Layout tab → Arrange group → Group. 
3. Click Group from the dropdown menu. 

To Ungroup: 

 Select the grouped object → Go to Arrange → Group → Ungroup. 

 

 Rotate: Rotates objects to any angle, either using preset options or custom degrees. 
 Selection Pane: Opens a pane to show all objects in the worksheet and lets you manage their visibility, 

order, and selection. 
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The Formulas tab provides tools to create, manage, and audit formulas and functions in Excel. It helps you perform 

calculations and manage data efficiently. 

 

Function Library 

The Function Library group in the Formulas tab provides a categorized collection of built-in Excel functions. 

These functions help perform calculations, analyze data, and manipulate text, dates, and more. 

 

AutoSum: 

Quickly adds totals using functions like SUM, AVERAGE, COUNT, MAX, and MIN. 

Financial: 

Functions for financial calculations, such as PMT, FV, and NPV. 

Logical: 

Functions like IF, AND, OR, and NOT used for decision-making formulas. 

Text: 

Functions for text manipulation, like CONCATENATE, LEFT, RIGHT, MID, LEN, etc. 

Date & Time: 

Functions to work with dates and times, such as TODAY, NOW, DATE, and DATEDIF. 

Lookup & Reference: 

Functions like VLOOKUP, HLOOKUP, INDEX, and MATCH used to find and retrieve data. 

Math & Trig: 

Includes functions like SUM, ROUND, ABS, INT, MOD, and more. 

More Functions: 

Access Statistical, Engineering, Information, and custom functions. 

 

Steps to Use a Function from the Library: 

1. Go to Formulas tab → Function Library group. 
2. Choose a category and select the desired function. 
3. A dialog box appears to help you enter the required arguments. 
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Defined Names 

The Defined Names group in Excel allows you to assign names to cells or ranges. These names make 

formulas easier to read, understand, and manage. 

 Define Name: 

Define Name allows you to give a custom name to a specific cell or range of cells, making formulas easier to 
understand and manage.  

Example: 

Instead of using a formula like: 

=SUM(A1:A10) 

You can define the range A1:A10 as Sales, then use: 

=SUM(Sales) 

Steps to Define a Name: 

1. Select the cell or range (e.g., A1:A10). 
2. Go to Formulas tab → Defined Names group → Define Name. 
3. Type the name (e.g., Sales2024) in the dialog box. 
4. Click OK. 

Note: Defined names must start with a letter and can't contain spaces (use underscores if needed). 

 

 

 

 

 

 Name Manager: 
Name Manager allows you to view, edit, delete, and manage all defined names in your workbook. 

Steps to Open Name Manager: 

1. Go to Formulas tab → Defined Names group → Name Manager. 
2. A dialog box will open showing all named ranges. 
3. Use New, Edit, or Delete buttons to manage the names. 

 Use in Formula: 
Quickly insert a defined name into a formula without typing it manually. 

Steps to Use: 

1. Start typing a formula (e.g., =SUM(). 
2. Go to Formulas tab → Defined Names group → Use in Formula. 
3. Select the defined name you want to insert. 
4. Finish your formula and press Enter. 
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Formula Auditing 

 Trace Precedents: 

Shows blue arrows pointing to the selected cell from the cells it depends on (input cells). 

 Trace Dependents: 

Shows blue arrows pointing from the selected cell to other cells that use its value in formulas. 

 Remove Arrows: 

Removes all precedent and dependent arrows from the worksheet. 

 Show Formulas: 

Displays formulas in cells instead of the results, making it easier to review and edit. 

 Error Checking: 

Scans the worksheet for common formula errors and gives explanations or fixes. 

 Evaluate Formula: 

Opens a dialog box to break down a formula step-by-step and show how Excel calculates it. 

 
 

Calculation 

 Calculate Now: 

Recalculates all formulas in the entire workbook immediately. 

 Calculate Sheet: 

Recalculates formulas only in the active sheet. 

 Calculation Options: 

Choose how Excel handles automatic updates: 

 Automatic: Excel recalculates formulas whenever a change is made. 

 Automatic Except for Data Tables: Recalculates all formulas except data tables. 

 Manual: Formulas update only when you click Calculate Now or F9. 
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The Review tab provides tools for proofing, protecting, and collaborating on your Excel workbook. 

 

Proofing: 

 Spelling: Checks and corrects spelling errors. 
 Thesaurus: Suggests synonyms for selected words. 
 Translate: Translates selected text into different languages. 

Accessibility: 

 Check Accessibility: Reviews your workbook for issues that may affect users with disabilities. 

Insights: 

 Provides quick access to Smart Lookup (definitions, web results, etc.). 

Comments: 

 New Comment / Show Comments: Add or review comments for collaboration. 
 Useful in shared workbooks for feedback and notes. 

Notes: 

 New Note / Show All Notes: Older version of comments for adding personal notes to cells. 

Protect: 

 Protect Sheet: Restricts editing of specific cells or the entire sheet. 

You can choose what actions are allowed (e.g., select cells, format, insert/delete rows). You can set a 
password to prevent unauthorized changes. 

 

Steps to Use: 

1. Go to Review tab → Protect group → Protect Sheet. 
2. Select the actions you want to allow. 
3. Enter a password (optional) and click OK. 

 Protect Workbook: Prevents structure changes like adding/moving sheets. 

Used to prevent changes to the workbook's structure, such as adding, deleting, or moving worksheets. You 
can set a password to block unauthorized modifications. 

 Allow Edit Ranges: Specify editable ranges for different users. 
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The View tab provides tools to control how the worksheet is displayed and how you interact with the workbook. 

 

Workbook Views: 

 Normal: Default view for everyday editing. 
 Page Layout: View how the workbook will look when printed, including headers, footers, and margins. 
 Page Break Preview: Displays the page breaks and allows you to adjust them. 

Show: 

 Gridlines: Show or hide gridlines in the worksheet. 
 Headings: Show or hide row and column headings (A, B, C... 1, 2, 3...). 
 Formula Bar: Show or hide the formula bar where you enter data or formulas. 

Zoom: 

 Zoom In/Out: Adjust the zoom level of the worksheet for easier viewing. 

Window: 

 New Window: Open a new window of the current workbook. 
 Arrange All: Arrange multiple workbook windows on your screen. 
 Freeze Panes: Used to lock specific rows or columns in place so they stay visible while you scroll through the 

rest of the worksheet. It helps in viewing headers or labels during data navigation. 

 

Select a cell below the row and/or to the right of the column you want to freeze. 
(e.g., to freeze Row 1 and Column A, click on cell B2) 

o Go to the View tab. 
o Click on Freeze Panes in the Window group. 

Choose one of the options: 

 Freeze Panes: Freeze rows above and columns to the left of the selected cell. 
 Freeze Top Row: Freezes only the first row. 
 Freeze First Column: Freezes only the first column. 

 Split: Split the window into separate panes for easier navigation. 

Macros: 

 Record Macro: Start recording a macro to automate tasks. 
 Use Macro: Run a macro that you’ve previously recorded. 
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  What is a Workbook in Excel? 
a) A single spreadsheet 
b) An Excel file containing worksheets 
c) A chart file 
d) A row of data 
Answer: b) An Excel file containing worksheets 

  What does a cell refer to in Excel? 
a) A row 
b) A column 
c) The intersection of a row and column 
d) A workbook 
Answer: c) The intersection of a row and column 

  Which bar displays the content of the active cell? 
a) Name Box 
b) Ribbon 
c) Formula Bar 
d) Task Pane 
Answer: c) Formula Bar 

  What is the maximum number of columns in 
Excel? 
a) 1024 
b) 1048576 
c) 16384 
d) 65536 
Answer: c) 16384 

  What does the Name Box display? 
a) Cell formula 
b) Workbook name 
c) Active cell address 
d) Sheet name 
Answer: c) Active cell address 

  Which command is used to copy formatting in 
Excel? 
a) Format Builder 
b) Paint Brush 
c) Format Painter 
d) Brush Tool 
Answer: c) Format Painter 

  Ctrl + X is the shortcut for: 
a) Paste 
b) Cut 

c) Copy 
d) Undo 
Answer: b) Cut 

  To apply bold formatting, use: 
a) Ctrl + I 
b) Ctrl + B 
c) Ctrl + U 
d) Ctrl + A 
Answer: b) Ctrl + B 

  Which option merges multiple cells and centers 
the content? 
a) Wrap Text 
b) Merge & Center 
c) Format Painter 
d) Align Center 
Answer: b) Merge & Center 

  Which option wraps text within a cell? 
a) Word Wrap 
b) Auto Fit 
c) Wrap Text 
d) Text Box 
Answer: c) Wrap Text 

  What does the Currency format display? 
a) Percentage symbol 
b) Scientific values 
c) Monetary values 
d) General numbers 
Answer: c) Monetary values 

  Which format shows values like 50%? 
a) Text 
b) Fraction 
c) Percentage 
d) Date 
Answer: c) Percentage 

  Which format would be used to enter '00123'? 
a) General 
b) Number 
c) Text 
d) Date 
Answer: c) Text 

  To decrease decimal points in numbers, you use: 
a) Decrease Decimal 
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b) Number Format 
c) Percentage 
d) Round Off 
Answer: a) Decrease Decimal 

  Which format shows data in scientific notation? 
a) Fraction 
b) Date 
c) Scientific 
d) Time 
Answer: c) Scientific 

  Which feature colors cells based on values? 
a) Cell Styles 
b) Data Bars 
c) Conditional Formatting 
d) Filters 
Answer: c) Conditional Formatting 

  Which formatting highlights cells between two 
values? 
a) Equal to 
b) Text that Contains 
c) Between 
d) Greater Than 
Answer: c) Between 

  What does Format as Table do? 
a) Adds chart 
b) Merges cells 
c) Formats data range as a table 
d) Converts text to number 
Answer: c) Formats data range as a table 

  What are predefined formatting styles called? 
a) Cell Styles 
b) Formats 
c) Tables 
d) Filters 
Answer: a) Cell Styles 

  Which feature helps in adding outer borders to 
cells? 
a) Wrap Text 
b) Format Cells 
c) Border Style 
d) Cell Merge 
Answer: c) Border Style 

  Which tool is used to add a series like 1,2,3...? 
a) Auto Number 
b) Auto Fill 
c) Auto Sum 
d) Sort 
Answer: b) Auto Fill 

  What does the Clear button NOT remove? 
a) Content 
b) Formatting 
c) Comments 
d) Worksheet 
Answer: d) Worksheet 

  Which command sums up selected cells? 
a) Count 
b) AutoSum 
c) Average 
d) Min 
Answer: b) AutoSum 

  Which command lets you find and replace text? 
a) Filter 
b) AutoFill 
c) Find & Replace 
d) Format Painter 
Answer: c) Find & Replace 

  Which tool helps sort data A to Z? 
a) Filter 
b) Sort & Filter 
c) Auto Sum 
d) Flash Fill 
Answer: b) Sort & Filter 

  Which tool summarizes large data quickly? 
a) Chart 
b) Table 
c) PivotTable 
d) Format as Table 
Answer: c) PivotTable 

  What does SmartArt create? 
a) Charts 
b) Diagrams 
c) Hyperlinks 
d) Conditional Formatting 
Answer: b) Diagrams 

  Which chart is used for comparing proportions? 
a) Pie Chart 
b) Line Chart 
c) Column Chart 
d) Bar Chart 
Answer: a) Pie Chart 

  Which feature inserts a clickable link? 
a) Text Box 
b) Comment 
c) Hyperlink 
d) Shape 
Answer: c) Hyperlink 
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  Which element lets you draw independent text? 
a) Cell 
b) Text Box 
c) Header 
d) WordArt 
Answer: b) Text Box 

  Which tab controls print orientation? 
a) View 
b) Insert 
c) Page Layout 
d) Review 
Answer: c) Page Layout 

  To print only selected cells, set: 
a) Print Option 
b) Print Area 
c) Scale to Fit 
d) View Area 
Answer: b) Print Area 

  Which option shrinks content to one page? 
a) Resize 
b) Page Fit 
c) Scale to Fit 
d) Compact 
Answer: c) Scale to Fit 

  Which orientation is vertical? 
a) Portrait 
b) Landscape 
c) Horizontal 
d) Upright 
Answer: a) Portrait 

  Which feature arranges objects like images? 
a) Organize 
b) Arrange 
c) View 
d) Design 
Answer: b) Arrange 

  Which function adds numbers? 
a) COUNT 
b) ADD 
c) SUM 
d) TOTAL 
Answer: c) SUM 

  What does the IF function do? 
a) Sorts values 
b) Performs condition-based action 
c) Filters values 
d) Counts numbers 
Answer: b) Performs condition-based action 

  What is the use of CONCATENATE? 
a) Adds numbers 
b) Joins text strings 
c) Sorts data 
d) Filters duplicates 
Answer: b) Joins text strings 

  Which function returns the current date? 
a) NOW 
b) DATE 
c) TODAY 
d) TIME 
Answer: c) TODAY 

  Which tab contains the Function Library? 
a) Insert 
b) Home 
c) Formulas 
d) Data 
Answer: c) Formulas 

  Which tool removes repeated values? 
a) Remove Values 
b) Filter 
c) Remove Duplicates 
d) Consolidate 
Answer: c) Remove Duplicates 

  What does Flash Fill do? 
a) Highlights cells 
b) Filters data 
c) Auto-fills based on pattern 
d) Converts numbers 
Answer: c) Auto-fills based on pattern 

  Which tool splits text into columns? 
a) Separator 
b) Split Cell 
c) Text to Columns 
d) Parse 
Answer: c) Text to Columns 

  Which feature groups rows or columns? 
a) Merge 
b) Border 
c) Group 
d) Combine 
Answer: c) Group 

  Which function creates subtotals? 
a) Total 
b) Sum 
c) Subtotal 
d) AutoFill 
Answer: c) Subtotal 
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  Which view shows headers and footers? 
a) Normal 
b) Page Layout 
c) Page Break 
d) Web Layout 
Answer: b) Page Layout 

  Which command freezes rows/columns in view? 
a) Lock Cells 
b) Freeze Panes 
c) Protect Sheet 
d) Pin View 
Answer: b) Freeze Panes 

  Which option checks spelling? 
a) Grammar 
b) Spelling 
c) Language 
d) Proof 
Answer: b) Spelling 

  What is the use of Protect Sheet? 
a) Hide cells 
b) Lock formatting 
c) Prevent editing 
d) Track changes 
Answer: c) Prevent editing 

  Which feature allows running automated steps? 
a) Script 
b) Function 
c) Macro 
d) Rule 
Answer: c) Macro 
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